Install problem with libAfterImage

I’ve been trying for quite awhile on and off again to get ROOT installed on my Linux Mint 17.1 Rebecca 64-bit. Compiling from source, since I can’t get the Ubuntu package to work for some reason and I can’t seem to find ROOT in Synaptic, ./configure works just fine (run with no additional options), but then during make (and quite a ways into it), I run into this show-stopper:

lib/libAfterImage.a(export.o): In function `ASImage2png_int': export.c:(.text+0x19c): undefined reference to `png_set_longjmp_fn' lib/libAfterImage.a(import.o): In function `png2ASImage_int': import.c:(.text+0x30ae): undefined reference to `png_set_longjmp_fn' collect2: error: ld returned 1 exit status make: *** [lib/] Error 1 make: *** Waiting for unfinished jobs....

I have libpng12 installed.

I found this solution here: Problems in building ROOT
But even though it says “solved,” I don’t really see a solution anywhere there…

Any other advice, or clearer advice than what’s in the only other ‘solution’ I’ve found?

Which ROOT version are you trying to install ?

Sorry, knew there was some detail I was forgetting. 6.05.02.

Can we also see the configure options you have ?
Doing have builtin_afterimage enabled ?
what gives the configure (or cmake) output ?