How can I change the default minimiser

Dear Experts,
can you please tell me how can I change the default minimiser ?
I would like to use Minuit2.
I’m using root_v5.34.00.patches and RooFit.

Many thanks,

  • Mauro.

ROOT User’s Guide -> Math Libraries -> Minuit2 Package

many thanks.
Are you super sure that it works also for RooFit ?
Because from the print out it doesn’t look like it’s working.
I mean, the print out on screen seems identical to the Minuit print out.


  • Mauro.

Did you already try this: … sPdf:fitTo

you just have to give an additional parameter to your fitTo() call of the PDF:

yourpdf->fitTo(yourdata, Minimizer(“Minuit2”,“migrad”))

I had problems however using many of the minimizers. In the log files I could see information that RooFit fell back using the default minimizer.

Hi Lukash,
many thanks.
It seems to be working with “Minuit2”.


  • Mauro.