H2root conversion failed with error

Dear root-team,

in the framework of the KADCADE Cosmic Ray Data Centre (KCDC) I got a hbook File long toime ago from a very old experiment (MaketAni) to publish via the KCDC DataShop.
Unfortunately this hbook File is the only data sample I have, but I cannot convert it to root.
The error message:

TFile*         /cr/kascade-kcdc/ANI/maket-lhest-045.root       HBOOK file: /cr/kascade-kcdc/ANI/maket-lhest-045.hbook converted to ROOT
RZIODO. Error at record =15629 LUN =  1003 IOSTAT =    -1
Bad sequence for RZHRIN          10

My question:

is there a way to tell h2root to convert up to a certain record and/or to convert from a certain record onwards?
I have no idea how many records are in this file.

I have tried with ROOT 5 and ROOT 6
Platform is Ubuntu 16.04.3 LTS

I was in contact with Oliver Couvet, he already downloaded the corrupted hbook file to one of your severs.

cheers Juergen

Please read tips for efficient and successful posting and posting code

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Hi Jürgen,

Thanks for your message on the forum. I tried several things to convert your hbook file… without success. It seems really corrupted.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.