Home | News | Documentation | Download

GL/glew.h not found when building root 6.20

Dear all,

After executing

cmake --build . ā€“ -j2

I am having the following fatal error when building root 6.20.02:

[ 62%] Building CXX object graf3d/ftgl/CMakeFiles/FTGL.dir/src/FTBitmapGlyph.cxx.o
In file included from /Users/torres/soft/root/root-6.20.02/graf3d/ftgl/src/FTBitmapGlyph.cxx:3:
In file included from /Users/torres/soft/root/root-6.20.02/graf3d/ftgl/inc/FTBitmapGlyph.h:9:
In file included from /Users/torres/soft/root/root-6.20.02/graf3d/ftgl/inc/FTGL.h:21:
**/Users/torres/soft/root/root-6.20.02-build/include/TGLIncludes.h:21:10:** **fatal error:** **'GL/glew.h' file not found**
#include <GL/glew.h>
**^~~~~~~~~~~**
1 error generated.
make[2]: *** [graf3d/ftgl/CMakeFiles/FTGL.dir/src/FTBitmapGlyph.cxx.o] Error 1
make[1]: *** [graf3d/ftgl/CMakeFiles/FTGL.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 62%] Built target BaseTROOT
make: *** [all] Error 2

glew 2.1.0_1 is already installed in my machine and it is apparently linked. I am running in mac os Catalina 10.15.3.

Thanks for helping!

Diego

1 Like

@oshadura looks like the same issue as in this other post, right?

1 Like

Hi! Can you please try to enable -Dbuiltin_glew=ON?

I opened Jira issue: https://sft.its.cern.ch/jira/browse/ROOT-10631

It worked now!
Thanks!

here is PR as well coming here: https://github.com/root-project/root/pull/5199

Could you please try if this fix help to solve situation when you have -Dbuiltin_glew=OFF (https://github.com/root-project/root/pull/5199)

Thanks a lot in advance!

Hi,
Executing with -Dbuiltin_glew=OFF , I have the following message:

[ 98%] Linking CXX shared library ā€¦/ā€¦/lib/libRGL.so
ld: library not found for -lGLEW
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/libRGL.so] Error 1
make[1]: *** [graf3d/gl/CMakeFiles/RGL.dir/all] Error 2
make: *** [all] Error 2

Cheers,

Diego

Hi,

Executing with -Dbuiltin_glew=OFF , I have the following message:

[ 98%] Linking CXX shared library ā€¦/ā€¦/lib/libRGL.so

ld: library not found for -lGLEW

clang: error: linker command failed with exit code 1 (use -v to see invocation)

make[2]: *** [lib/libRGL.so] Error 1

make[1]: *** [graf3d/gl/CMakeFiles/RGL.dir/all] Error 2

make: *** [all] Error 2

Cheers,

Diego

Hi! Sorry for late reply, I wanted to reproduce your failure and I wanted to ask how did you install Glew?

Hello,
I did this: brew install glew

Diego

At the end, sadly it appears to be a bug in CMake 3.15-3.17, and we disabled for Mac OS X an option with builtin_glew=OFF. Out of curiosity, we would like to ask you why you needed install glew from brew (it it a requirement of other application)?

Thank you again so much for your report!

Hello,
Thanks for fixing it! About glew, it seems that it was not installed in my machine (and I do not know if I need for any other application).

Cheers