Gif file with other window in it

I’m using ROOT 4.04.02b that I have compiled from source on my system (scientific Linux 4.3) with opengl fetaure.

When I use the method TCanvas::SaveAs(“name.gif”), the gif file doesn’t have the canvas image but an image of the active window on my system (in most of the cases I have an image of the shell). This doesn’t happen if I save an eps file.

Is there a way to fix it?

Thank you very much,

Can you try with a more recent ROOT version ?
Do you have a example reproducing this problem ?

I’ve tried with ROOT 5.12, compiled just like I did for ROOT 4.04.02b, and it works good, i.e. the gif file has the plot.

I discovered this problem running a macro, but I’ve tried also with a simpler example:

TH1F *histo=new TH1F(“histo”,“histo”,100,-10,10)

…and gif file that I get is attached with this message.

Ok good, so it is fixed now. Thanks to have tried.

Ok, but do you have any clue on what could be the problem with ROOT 4.04.02b?

I would like to try and fix it, so all the suggestions are very welcome.

No … many things have changed since that version … I can check if you really need an answer, but that may takes time. 4.04.02b is almost 2 years old (we are at 5.14 now).
One which machine are you running ?
Do you produce the gif in batch mode ? (any canvas opened)

Well I’m using this kind of version to be 100% compatible with the version that is included in the release tag of my analysis.

My machine is a Linux i686, and I’m not running in batch mode. The canvas displays the correct plot, only the gif file has this strange behaviour.

Anyway I dont’t want to bother with this issue, if is time consuming to solve it. All in all
I can create the eps file and then produce the gif file using “convert”.

Or maybe I can try to recompile ROOT using different options and see what happens.


I am surprised that it does not work if you are not in batch mode, because this feature is working for a long time in “non-batch” mode. The last developments in that area were to make it work in batch mode.

This suggests that perhaps is problem of my personal build.