Gif animation error

I have an analysis code which I use a bash script to loop through a series of parameters. I have the canvas saved as a gif for each iteration which produces a nice animation showing how the result varies with the parameter change.

The canvas is saved as:c2->Print("TESTING.gif+25");

I have used this successfully. However, I have since upgraded my laptop and root version and now I get the following error: “Error in TASImage::WriteImage: error writing file testing.gif+25”

I’m now using Root version 5.34/14, whereas previously I used 5.34/03 which produced the required .gif animation. The rest of the code works fine it is just the save to .gif animation that fails.

I’ve tested using SaveAs instead of print and the same error occurs, and I have tested using hsumanim.C from, as before, the code runs fine, but the same error occurs when trying to save the animated .igf file.

I’ll check

It works fine for me:

$ root -b hsumanim.C
  *                                         *
  *        W E L C O M E  to  R O O T       *
  *                                         *
  *   Version   5.34/35    2 October 2015   *
  *                                         *
  *  You are welcome to visit our Web site  *
  *            *
  *                                         *

ROOT 5.34/35 (v5-34-34@v5-34-34, Feb 10 2016, 17:35:00 on macosx64)

CINT/ROOT C/C++ Interpreter version 5.18.00, July 2, 2010
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0] 
Processing hsumanim.C...
i = 500
i = 1000
i = 1500
i = 2000
i = 2500
i = 3000
i = 3500
i = 4000
i = 4500
i = 5000
i = 5500
i = 6000
i = 6500
i = 7000
i = 7500
i = 8000
i = 8500
i = 9000
i = 9500
hsum      : Real Time =   1.32 seconds Cpu Time =   0.83 seconds
root [1]

Hi, mtagg,
do you have write permissions in the folder you are trying to save?

And check about capital letters (TESTING or testing)?

The permissions should be fine. My code also saves .png and .root files for each iteration. Those still work, as does the output file for the results. It’s just the .gif section that returns the error.

I guess it has to be my installation then. Thanks for your help.

On what kind of machine are you running your hsumanim.C ?

A Dell Latitude E5550 running Ubuntu 14.04. I’m using root 5.34/14, I’m not sure why it wasn’t given a more up-to-date version.

Yes, may be a more recent version would help.

Errors or malfunctioning after upgrades/updates are most common and repetitive issue with all laptops. But there are many methods written in Dell Latitude E5550 Manual that may fix it such as rebooting, increasing some versatile memory, re installation of tools/applications/software etc. So check it and fix the issue with easy and result-oriented hacks.

This post does not seems related with the initial question.