Getting Root started on Windows

Hello all,
I am attempting to get Root up and running on my Windows machine (if this fails I guess I will partition my hard drive to run Linux). I see there have been a few questions on this but the responses don’t quite address my situation.

I am getting the below error when I run Root from the VS x86 Command Prompt:

input_line_1:1:10: fatal error: ‘new’ file not found
Assertion failed: OldBuilder->DeferredDeclsToEmit.empty() && “Should have emitted all decls deferred to emit.”, file C:\build\ws\BUILDTYPE\Debug\LABEL\windows10\V\6-26\root\interpreter\llvm\src\tools\clang\lib\CodeGen\ModuleBuilder.cpp, line 147

ROOT Version: 6.26.00
Platform: windows 10
_Compiler:_visual studio 2019 (Windows x86 Command Prompt)
Dependencies: Visual Studio 2019 C++, CMake, Python, Windows SDK

I do not know if my issue is opening Root from the wrong file or using the wrong command, or if my dependencies are not in the right files, or if I built it incorrectly from the .exe.
Thank you all, please be gentle, I don’t know VS or Root that well yet.

Welcome to the ROOT forum.
Our Windows expert, @bellenot, may help you.

Are you sure you start from a x86 Native Tools Command Prompt fo VS 2019? You should see something like this:

** Visual Studio 2019 Developer Command Prompt v16.11.11
** Copyright (c) 2021 Microsoft Corporation
[vcvarsall.bat] Environment initialized for: 'x86'

thank you for the rapid response. my prompt did not look like that, I dug into starting Native Tools x86 and that worked! For those of you who encounter this issue - you need to go into the Visual Studio directory and open the developer command prompt from there, not using the Tools menu inside the VS application.

1 Like