Font problem in plot

Some Symbols ( Sigma ) dosn’t display in my plots and just a empty rectangle will display !
According to this
I tried :

ls -l /etc/fonts/conf.d/30-urw-aliases.conf 

but dosn’t solve my problem .
I have two system with ubuntu 16.04, this is very amazing that one of them works well but the other does not! both have same ubuntu and same root version , and i used same commands for plotting.

I attached two image that one of them is plotted in one system correctly and the other in another system.



as you can see in image 1, sigma symbol can’t be displayed.
what is problem and how we can solve this?

Greeks characters are taken symbol.ttf in the fonts folder of the ROOT installation:

% ls $ROOTSYS/fonts
BlackChancery.ttf	FreeSansOblique.otf	STIXGeneralItalic.otf	STIXSiz5Sym.otf		courbd.ttf		symbol.ttf		verdana.ttf
DroidSansFallback.ttf	FreeSerif.otf		STIXSiz1Sym.otf		arial.ttf		courbi.ttf		times.ttf		verdanab.ttf
FreeMono.otf		FreeSerifBold.otf	STIXSiz1SymBol.otf	arialbd.ttf		couri.ttf		timesbd.ttf		verdanai.ttf
FreeMonoBold.otf	FreeSerifBoldItalic.otf	STIXSiz2Sym.otf		arialbi.ttf		georgia.ttf		timesbi.ttf		verdanaz.ttf
FreeMonoBoldOblique.otf	FreeSerifItalic.otf	STIXSiz2SymBol.otf	ariali.ttf		georgiab.ttf		timesi.ttf		webdings.ttf
FreeMonoOblique.otf	LICENSE			STIXSiz3Sym.otf		ariblk.ttf		georgiai.ttf		trebuc.ttf		wingding.ttf
FreeSans.otf		STIXGeneral.otf		STIXSiz3SymBol.otf	comic.ttf		georgiaz.ttf		trebucbd.ttf
FreeSansBold.otf	STIXGeneralBol.otf	STIXSiz4Sym.otf		comicbd.ttf		impact.ttf		trebucbi.ttf
FreeSansBoldOblique.otf	STIXGeneralBolIta.otf	STIXSiz4SymBol.otf	cour.ttf		monotype.ttf		trebucit.ttf

thanks for your reply .

i checked fonts in root installation directory .( /usr/share/root/fonst), i have symbol.ttf


but its seems root don’t using this fonts

Is the variable $ROOTSYS defined ?

No , when i tried ls $ROOTSYS/fonts, this error occured :

ls: cannot access /fonts: No such file or directory

Also when i use cd $ROOTSYS, nothing happen.

Note : Root was installed by default in ubuntu 16.04 . i don’t installed it from any website.

You need to have ROOTSYS defined. In the place where ROOT is installed you have a folder called bin. It contains You should “source” that file.

$ source where_root_is_installed/bin/

Usually you put this command in your .profile or equivalent.

i searched for but this bash file dosn’t exists . i used ubuntu 16.04 that have root package by default, so i didn’t install it with wget .

i only have a file exists in /usr/bin. and when i use :


root get stated .

Hi @keyvan_127.0.0.1 ,
how did you install ROOT exactly? with apt-get install root or similar? The ROOT package in the ubuntu repos is out of date (I didn’t think it was still there). Or was it via Snap?


You said that you have the folder /usr/share/root/fonts . So it looks like your root version is installed in /usr/share/root/ . In that case you find the thisroot* files in /usr/share/root/bin

(note that this being a system installation of ROOT from a package manager, it might not even have a

There’s ROOT 5.34 in Ubuntu’s 16.04 repositories, and the installation doesn’t look like Snap to me, Snap will never put entries into /usr/bin.

Please keep in mind Ubuntu 16.04 goes into End of Life support this month and will stop recieving security and maintainence updates. I’d really recommend upgrading to a newer system aside from the ROOT issues you may be having.

The ROOT team provides ready-to-use binary distributions for some systems (see “Download a pre-compiled binary distribution” therein), including various Ubuntu versions, which you just need to download and unpack. For Ubuntu 16.04 / x86_64 / gcc 5.4:;O=A;P=*[uU][bB][uU][nN][tT][uU]*16*

BTW. Before using it, make sure that you “completely remove” (“purge”) all “system-provided” ROOT related packages.

My main problem is as follows :
i have two machines, one of them is thinkpad X131e and another one is thinkpad T440.

I use exactly same packages for my researches and exactly same ubuntu version ! but it is very strange for me when i plot my result, the first machine give me full notations but the second one cannot display some notations specially sigma notation.

in short, all of things are completely same in two machines but the second machine can not support from some mathematical notation ( such as sigma) in my plotes.

Assuming you installed ROOT via apt-get, I don’t think we can help much, that package corresponds to an unmaintained ROOT version (v5.34) and the package itself is also unmaintained.

See for various ways in which it is possible to install a recent ROOT version, including a list of dependencies at

If issues persist, we can then probably help.


Compare the list of fonts that are installed on both machines:
dpkg -l "*[fF][oO][nN][tT]*" | grep ii