Font in interactive window illegible

Since today, whenever I use root interactively and want to save a histogram, the window showing the files in the directory where I want to save the histogram has an illegible font. This happens with either version of root mentioned below, both of which I have used in the past year without a problem. My guess is that somehow I have installed something else that interferes with the fonts in this window, but I don’t know how to fix that.

_ROOT Version: 6.18/00 and 6.16/00
_Platform: Ubuntu 18.04.6 LTS
_Compiler: g++

Weirdly, I tried to do the same with yet another root version on machine (6.26/10), and with this version the window looks fine.
Can someone tell me how to fix it for the other versions of root that I use? (I need those other versions too, because some of my software is compiled against those versions).

ROOT Version: 6.26/10

Hi @machiel,
thank you for posting on the ROOT forum!

I have no clue of what the root cause could be. Maybe @couet could help with this.

I see that you can browse to the folder in which you what to save the file (the browsing bar at the top is readable), so you should be able to access the save functionality anyway.


Yes, I could save the files, but the font of the files already in the directory was un-readable. But I fixed it just now. I had to do:

sudo apt-get remove xfonts-100dpi:amd64

Apparantly, older versions of ROOT don’t like the “xfonts-100dpi” package


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.