Fatal error: 'RooGlobalFunc.h' file not found

Dear Root experts,
I have installed “ROOT 6.28/04” recently using “yum install” on RHEL9.2.
I am aware that the mentioned Root release is for Centos8 but I have no choice but using RHEL9.2 since that is the only OS available.
Everything works pretty well except RooFitting. When I try my fitting code, I receive the following error:
fatal error: ‘RooGlobalFunc.h’ file not found
After some search, I came across the following suggestion by @Wile_E_Coyote

RooFit doesn't find .h files

When I execute the suggested command I get “yes”.
Again, I know that the Root release is not supposed to be installed on RHEL9 but I was wondering if you can help me get it to work.
Any suggestions is appreciated

By the way, I am sure the fitting code has no problems since it worked on older versions of Root (installed on the right OS)

i guess @jonas can help you.

Thank you @couet

I also tried to install root using conda. I installed miniconda3 and successfully installed root with no error. However, when I try to compile and run my code, I receive the following warning:

Warning in cling::IncrementalParser::CheckABICompatibility():
Possible C++ standard library mismatch, compiled with GLIBCXX ‘20220421’
Extraction of runtime standard library version was: ‘20230528’

I can try any suggestions for both method of installation, miniconda or yum.

Thanks a lot

Dear experts,
Sorry for sending a lot of replies, but I thought this might be helpful.
Despite the warning message (in the previous reply) I receive, it seems that my code is running fine and produces expected results.
Should I just ignore the warning? I am worried it might cause problems later.

Hi @Natilus,

well, if your code doesn’t crash even with the library mismatch warning, it just means that you’re probably not using the standard library components that have a different ABI, so everything is fine and I would ignore the warnings.

But still, it’s maybe better and easier to install ROOT with yum because you don’t need the conda environment.

I think in Fedora and RHEL packages, even though ROOT is built with RooFit enabled (and hence you the the “yes” from root-config), the headers and libraries are split over separate packages:

Did you also install the root-roofit* packages?

Hi @jonas ,
Thank you very much for your response.
I actually installed root-roofit-core yesterday after I got the error message:
fatal error: ‘RooGlobalFunc.h’ file not found
This solved the error; however, many header files such as RooExponential.h was missing.

I guess, as you suggested, I can install Root using Yumn and afterwards, install root-roofit-core.
What other packages should I install for the missing header files?
Is it enough to install root-roofit* packages?

Thank you,

Dear @jonas ,
Once again, thank you for your help.
As I mentioned, I installed Root using Yum and all the RooFit packages you suggested.
I no longer get the error messages or missing header files. My code runs successfully.
Thank you again.