Failing to load from a multithreaded geant4 job with ROOT 6.24.00 and 5.34.19

I am having some trouble running multithreaded jobs in geant4 10.02.p03 with the jobs crashing with the message:
" error while loading shared libraries: failed to map segment from shared obj
ect: Cannot allocate memory"
I have tried with the two root versions on our cluster 6.24.00 and 5.34.19 and had the same result.
I am running on RHL7, cmake is 3.22.2 and gcc 8.3.1

I am note sure if this is related to root installation, multithreading or something else. I would really appreciate any help.

Welcome to the ROOT forum
As it seems related to a Geant4 job, did you ask the Geant4 Forum ?

Thanks Olivier for your prompt response. I will ask the Geant4 forum.

1 Like

This indicates that this may be a problem with your local setup (like being out of memory, or lack of permissions). You should try to understand why memory allocation failed. Also, is a library from ROOT 6 only, so it will not work if you try with ROOT 5.34. I recommend checking which version of ROOT Geant4 10.02.p03 was linked against and use that version of ROOT, otherwise you will probably end up using incompatible libraries and cause a crash. First, however, the memory allocation problem needs to be solved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.