Error message: The versions of libVc.a (1.4.1) and Vc/version.h (1.4.3) are incompatible. Aborting. Aborted


I have a little problem and need help. I am trying to run a code that I got from a course that I’m doing at university. I copied the code (C++) from the university’s computer to my laptop, so that I can also work from home. The code compiled on the university’s computer (using a makefile that was already written for me and I should not change anything in the makefile). After executing the makefile with “make”, this is what I get (on the universitiy’s computer and on my laptop):

zobeyer@Zobi-Laptop:~/Advanced_Lab_Course_I/KT.HIP/Test2$ make
g++ -c -g -Wall -pthread -std=c++14 -m64 -I/home/zobeyer/root/include Analysis.cpp -o Analysis.o
g++ -I/home/zobeyer/root/include runAnalysis.o Analysis.o AnalysisHelpers.o -o runAnalysis -std=c++1y -L/home/zobeyer/root/lib -lGui -lCore -lImt -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lROOTVecOps -lTree -lTreePlayer -lRint -lPostscript -lMatrix -lPhysics -lMathCore -lThread -lMultiProc -lROOTDataFrame -pthread -lm -ldl -rdynamic

This is all good but for the next step, I get this error message after typing “./runAnalysis -i ggf -i vbf -o signal” and executing it. The error message i get is:

zobeyer@Zobi-Laptop:~/Advanced_Lab_Course_I/KT.HIP/Test2$ ./runAnalysis -i ggf -i vbf -o signal
The versions of libVc.a (1.4.1) and Vc/version.h (1.4.3) are incompatible. Aborting.

It works in the computer at my university and I get what i want but not on my laptop. I tried googling it but I could not find a solution. The second execution works on the computer of the university but not on my laptop. Does anyone have an idea, how i can fix this?


EDIT: fyi, the folder path of the libVc.a file is: /home/zobeyer/root/lib/libVc.a. And using sudo infront of “./runAnalysis -i ggf -i vbf -o signal”, so that “sudo ./runAnalysis -i ggf -i vbf -o signal”, I get an error message that I got before but was able to fix it through this solved-libcore-so-cannot-open-shared-object-file-no-such

zobeyer@Zobi-Laptop:~/Advanced_Lab_Course_I/KT.HIP/Test2$ sudo ./runAnalysis -i ggf -i vbf -o signal
[sudo] password for zobeyer:
./runAnalysis: error while loading shared libraries: cannot open shared object file: No such file or directory

ROOT Version: 6.24/02 (Build for linuxx8664gcc)
Platform: Ubuntu 20.04.5 LTS
Compiler: GCC 9.4.0 x86_64-linux-gnu

Welcome to the ROOT forum.

It looks like libVc is not properly installed on your computer.
Let’s ask @moneta. He will surely have some hints

Thank you! I’ll wait for @moneta to reply :slight_smile:

I solved it by just updating root/updating its dependencies (following the steps for download a pre-compiled binary distribution) and after updating the dependencies, I executed this to update root to a newer version:

$ wget
$ tar -xzvf root_v6.28.04.Linux-ubuntu20-x86_64-gcc9.4.tar.gz
$ source root/bin/