Error matrix is NumCPU dependent in weighted LL fits?

I am experiencing a funny result with a RooFit fit to a RooDataSet with weights using an maximum likelihood fit.

I tested using a constant weight value of 16, and found that my errors had reduced by a factor of 4 !
I fit with the command

RooFitResult * fitResult = model->fitTo( *dsSet,Strategy(2),Save(kTRUE),Timer(kTRUE),NumCPU(12), SumW2Error(dsSet->isWeighted() ? kTRUE:kFALSE));

However, if I set the number of cpu’s to one, i.e. NumCPU(1), then the errors returned are corrected to the by the weights, and I get back the same result as when I supplied no weights.

Can somebody confirm this issue, and also supply a (temporary?) remedy, as I would like to keep multi-core enabled.
I have tried this on the default version of RooFit supplied with Root 5.28/00b and 5.27/06

Many thanks.