Home | News | Documentation | Download

Error in cling::CIFactory::createCI() when opening ROOT

Hello,

When I type root in the terminal to open it, I see the following error message before ROOT opens:

ERROR in cling::CIFactory::createCI(): cannot extract standard library include paths!
Invoking:
  LC_ALL=C x86_64-linux-gnu-g++-7  -O3 -DNDEBUG -xc++ -E -v /dev/null 2>&1 >/dev/null | awk '/^#include </,/^End of search/{if (!/^#include </ && !/^End of search/){ print }}' | GREP_OPTIONS= grep -E "(c|g)\+\+"
Results was:
With exit code 256

This error message also appears when I run the .exe file of a C++ program with a ROOT object in it.

I did check out this thread, which appears to show the same exact error as mine. The original poster solved their problem by updating/installing some missing prerequisites. I checked and all the prerequisites mentioned here (required and optional) are installed and updated.

I am using ROOT 6.14/06 and ubuntu 19.04.

Does anyone know how I can solve it? Do I have to re-build ROOT?

Thank you,
Filipa

@amadio took care of the ticket you mentioned so he should be able to help you with this.

Not really, I improved the check to need only sed, but in the end the problem was that either awk or grep were missing in that person’s computer. Please ensure that you have both installed on your machine, or try to use a newer version of ROOT and ensure you have sed installed. Cheers,