Error 127 in compiling ROOT - bin/rmkdepend

Helo everyone!

I’m to trying install the ROOT 5.32 in my notebook that have installed the OpenSuse 12.3, and that verified every prerequisites to ROOT in Suse. Furthermore I have too verified various components of the compilers c++. But I’m can’t run completely the make! The process begin and stop after some compilations with the message:

gcc -O2 -pipe -m64 -Wshadow -Wall -W -fPIC -Iinclude -pthread -DINCLUDEDIR="/usr/include" -DOBJSUFFIX=".o" -o build/rmkdepend/ifparser.o -c /home/wolborg/root/build/rmkdepend/ifparser.c
gcc -O2 -pipe -m64 -Wshadow -Wall -W -fPIC -Iinclude -pthread -DINCLUDEDIR="/usr/include" -DOBJSUFFIX=".o" -o build/rmkdepend/cppsetup.o -c /home/wolborg/root/build/rmkdepend/cppsetup.c
gcc -O2 -pipe -m64 -Wshadow -Wall -W -fPIC -Iinclude -pthread -DINCLUDEDIR="/usr/include" -DOBJSUFFIX=".o" -o build/rmkdepend/main.o -c /home/wolborg/root/build/rmkdepend/main.c
/home/wolborg/root/build/rmkdepend/main.c:64:12: error: conflicting types for ‘fchmod’
In file included from /home/wolborg/root/build/rmkdepend/def.h:42:0,
from /home/wolborg/root/build/rmkdepend/main.c:30:
/usr/include/sys/stat.h:298:12: note: previous declaration of ‘fchmod’ was here
Running /home/wolborg/root/build/unix/
Making include/compiledata.h
Running /home/wolborg/root/cint/ROOT/
Making cint/cint/inc/configcint.h
bin/rmkdepend -R -fcint/cint/src/g__cfunc.d -Y -w 1000 – -pipe -m64 -Wall -W -fPIC -Iinclude -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__64BIT -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -I/home/wolborg/root/cint/cint/inc -I/home/wolborg/root/cint/cint/src -I/home/wolborg/root/cint/cint/src/dict -pthread -I. – /home/wolborg/root/cint/cint/src/g__cfunc.c
make: bin/rmkdepend: Comando não encontrado
make: ** [cint/cint/src/g__cfunc.o] Erro 127

What can be?
Would be possible solve this problem copying the files generated in this process in other PC? No solve this problem would be a problem to ROOT after.

If someone can help me, I thank so much!

I also encoutered the same situation,and I install root5.28 in ubuntu 13.10. can somebody help me out the issue?


Hi Hui,

We strongly recommend you use the latest ROOT 5.34. 5.28 is known to no work on Ubuntu 11 and up (which were published after 5.28).


Hi Philippe,
Thanks for your help1 I have installed 5.34 successfully, but when I run root,there are some notes as follows. Does it matter or how can I do next?

Couldn’t find font “-adobe-helvetica-medium-r---10-----*-iso8859-1”,
trying “fixed”. Please fix your system so helvetica can be found,
this font typically is in the rpm (or pkg equivalent) package
XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi.

  •                                     *
  •    W E L C O M E  to  R O O T       *
  •                                     *
  • Version 5.34/09 26 June 2013 *
  •                                     *
  • You are welcome to visit our Web site *
  •      [](            *
  •                                     *

ROOT 5.34/09 (heads/v5-34-00-patches@v5-34-08-80-g1323c6f, Jul 03 2013, 18:18:00 on linuxx8664gcc)

CINT/ROOT C/C++ Interpreter version 5.18.00, July 2, 2010
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.


In the file etc/system.rootrc or in your .rootrc file do you have :

Unix.*.Root.UseTTFonts: true


Unix.*.Root.UseTTFonts: false


[quote=“pcanal”]Hi Hui,

We strongly recommend you use the latest ROOT 5.34. 5.28 is known to no work on Ubuntu 11 and up (which were published after 5.28).


In my case, the version 5.34 of the ROOT not solve all! The compilation stop in other error associated to with the message:
collect2: ld returned 1 exit status
make: *** [walt] Error 1

I have :
Unix.*.Root.UseTTFonts: true

Thanks for help!

It looks like X11 is not properly installed on your machine.

I not see this possible… I have installed every prerequisites to install ROOT. Well, anyway I tried of various way (using too some ideas of same problems related here but without sucess) and I don’t have very help here in this topic, so, I installed other distribuition linux (Debian) and now, everything is ok…