Epstopdf root plots with greek letters

Dear Rooters,
i’ve a problem in eps root file conversion to pdf.
Greek letters like latex \Delta (inserted in axis name with #Delta)
are not converted with epstopdf or convert, a empty set symbol
is instead visualized ! (0 with line)

I’ve all plots in eps and rendering in jpg is not so good as in pdf conversion, do you have any suggests to solve this problem ?

At the end i need or a correct pdf or a jpg with better resolution that with convert file.eps file.jpg.

Many thanks,

I will look at it. But why don’t you generate PDF directly from ROOT instead of making this conversion ?

I tryed on my system (CVS version of ROOT, FC 6, epstopdf 2.9.3draft) without any problem.


Thanks, in the future i’ll do, problem is for all already done plots (e.g. my phd thesis) that are in eps and i would avoid to redo all plots for a delta symbol …


I tried to convert an eps file containing #Delta into a pdf one, using epstopdf and for me it is working fine. The eps file was generated with the latest ROOT version. Do you have a little macro or an eps file showing the problem ?

Ok i’ve tried with root 5.13 and it’s ok, problem was in 5.11.
Thanks for your interst guys !!


By the way, if you have tried with 5.13 it does mean that you are able execute macros to regenerate the files. In that case, as I said before, you can generate PDF directly.

Hi Massimiliano,
to convert EPS file into image file

  • the simplest way:

    1. in root session run TBrowser and click on eps file … new canvas with
      content of eps file will be displayed.
    2. Save canvas as PNG , GIF image which provides better quality than JPG format
  • to automate this procedure follow :
    TImage *im = TImage::Open(“my.eps”)

Note, the later method works in batch mode also.

Regards. Valeriy