Curl -o is not recongnized by root

Dear community,

I am a new user in root / tmva. As I tried to run TMVAClassification in root under Windows, I got following message:
“can not find command curl”
It seems that the error happens at the statement :
gSystem->Exec(“curl -O”);
Can any one help me to resolve the problem ?
To work around the problem I tried to copy tmva_class_example.root to my local disk. (acturally it istmva_example.root there.) But the newly established file is not readable by the program. Where can I get a corresponding working file ?
Just to mention again that I am using root in Widows 7.

Thanks in advance !

curl -> downloads

The command you give as argument to gSystem->Exec is passed to the local operating system to be executed. ROOT does not check if the command exists or not. It is your responsibility to make sure the command is valid and exists. As Wile suggested you have to download it .

You can also just download the file and place it in a folder “./files/tmva_class_example.root” relative to the directory you run the script from.

TMVA first checks if the file is cached locally before trying to fetch it from the interweb. Thanks for reporting that this does not work out-of-the-box for windows!


Dear Wile_E_Coyote, couet and kialbert

Thanks to your instant answers my question. I feel warm and welcomed here!

I have just installed the curl in bin directory and it seems there is no more trouble at this statement.

But I encountered another problem I got a following message: “ Failed to connect to port 80: connection refused”
I guess this is caused by my intranet or fire wall of the company. I am trying to resolve the problem
or a local training file will get around the trouble. How can I download the file tmva_esample.root from cern ? FTP ?



Replace “http://” with “https://”.

Or click the link in your first post :wink:


Dear Kim,

I didn’t realize there is a link in my first post.

You mentioned: „ You can also just download the file and place it in a folder “./files/tmva_class_example.root” relative to the directory you run the script from. “. Can you please kindly tell me where to download the toy training file for TMVAClassification ? Should I use FTP ? Does Cern has a FTP server ?



For each file that you want to run, you can find the download location near the top of the file. Ofc, if you followed @Wile_E_Coyote’s suggestion you should be able to run the example directly.

The files are served by an ordinary webserver, hence you just need to paste the url in your browser.


Thanks for mention me.

Instead IE I uased firefox. Then I got an option to store the file in firefox. Now it works. I wonder why IE does not give this option. I saw only junks from a bin file.