Compiling 6.28.04 on OSX Ventura 13.4

Hi all, trying to build 6.28.04 from source on my mac Ventura. The default compilation worked fine, but I needed to use cxx17 because other codes to be compiled against this root need that.
I used these commands:

mkdir root_src; cd root_src
tar zxf ./root_v6.28.04.source.tar.gz	
mkdir install
mkdir build
cd build
	-DCMAKE_INSTALL_PREFIX=/Users/wjllope/root_src/install ../root-6.28.04/ \
	-Dbuiltin_glew=ON -Dbuiltin_openssl=ON -DCMAKE_BUILD_TYPE=Release
cmake --build . --target install

this worked fine for quite a ways until this:

[ 58%] Built target SPlot
[ 58%] Generating G__ROOTVecOps.cxx, ../../lib/ROOTVecOps.pcm
In file included from input_line_10:3:
/Users/wjllope/root_src/build/include/ROOT/RVec.hxx:536:9: error: no member named 'uninitialized_value_construct' in namespace 'std'
   std::uninitialized_value_construct(first, last);
Error: /Users/wjllope/root_src/build/bin/rootcling: compilation failure (/Users/wjllope/root_src/build/lib/libROOTVecOps314929abb2_dictUmbrella.h)
make[2]: *** [math/vecops/G__ROOTVecOps.cxx] Error 1
make[1]: *** [math/vecops/CMakeFiles/G__ROOTVecOps.dir/all] Error 2
make: *** [all] Error 2

Any suggestions? thanks! cheers

I am using these cmake flags on my Ventura machine and it is working fine:

-Dhttp=ON -Droot7=ON -DCMAKE_CXX_STANDARD=17 -Dall=ON -Dbuiltin_xrootd=ON
1 Like

Thanks! I will try your settings in a second.
As an aside, I also tried using this command:

cmake --build . --target install -- -j4

instead of the previous

cmake --build . --target install

and now root seems to be compiling fine. I guess I don’t understand cmake yet! Thanks again for your example. cheers

Hi again - I managed to build root - thanks. But for completeness there was another issue.
I tried

cmake -Dhttp=ON -Droot7=ON -DCMAKE_CXX_STANDARD=17 -Dall=ON -Dbuiltin_xrootd=ON \
	-Dbuiltin_glew=ON -Dbuiltin_openssl=ON -DCMAKE_BUILD_TYPE=Release \
	-DCMAKE_INSTALL_PREFIX=/Users/wjllope/root_src/install ../root-6.28.04/ 
cmake --build . --target install -- -j4

and the compilation died here:

	[ 79%] Building CXX object math/quadp/CMakeFiles/Quadp.dir/src/TQpDataSparse.cxx.o
	[ 79%] Built target Tree
	[ 79%] Building CXX object math/quadp/CMakeFiles/Quadp.dir/src/TQpLinSolverBase.cxx.o
	In file included from input_line_9:3:
	/Users/wjllope/root_src/build/include/RExports.h:64:9: fatal error: 'RcppCommon.h' file not found
	[ 79%] Building CXX object hist/hist/CMakeFiles/Hist.dir/src/AnalyticalIntegrals.cxx.o
	[ 79%] Generating G__Physics.cxx, ../../lib/Physics.pcm
	[ 79%] Building CXX object hist/hist/CMakeFiles/Hist.dir/src/Haxis.cxx.o
	[ 79%] Generating G__Proof.cxx, ../../lib/Proof.pcm
	[ 79%] Generating G__ROOTNTupleUtil.cxx, ../../lib/ROOTNTupleUtil.pcm
	[ 79%] Building CXX object math/quadp/CMakeFiles/Quadp.dir/src/TQpLinSolverDens.cxx.o
	Error: /Users/wjllope/root_src/build/bin/rootcling: compilation failure (/Users/wjllope/root_src/build/lib/libRInterfacef47af70574_dictUmbrella.h)
	make[2]: *** [bindings/r/G__RInterface.cxx] Error 1
	make[1]: *** [bindings/r/CMakeFiles/G__RInterface.dir/all] Error 2
	make[1]: *** Waiting for unfinished jobs....
	[ 79%] Building CXX object hist/hist/CMakeFiles/Hist.dir/src/HFitImpl.cxx.o
	[ 79%] Linking CXX shared library ../../lib/
	[ 79%] Built target ROOTHist

…a different error than my earlier one (but both involving somehow bla_dictUmbrella.h FWIW)

So, again i scorched the build directory and tried this:

	-Dbuiltin_glew=ON -Dbuiltin_openssl=ON -DCMAKE_BUILD_TYPE=Release \
	-DCMAKE_INSTALL_PREFIX=/Users/wjllope/root_src/install ../root-6.28.04/ 
cmake --build . --target install -- -j8

and then root built and installed, and runs, just fine. The only difference between cmake configure commands (between my first one and the one that worked) was the ordering of the -D switches in the command. Which a bit unsettling… ;^)
ANyway, very happy with my shiny new root - thanks again!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.