Can't load MathMore

Hi ROOTers,
this is my first post, so try not to kill me if i’m too noob :slight_smile:
for mathematical purposes, i need to use, in ROOT, a Kummer confluent hypergeometric function, but when i run the command

root[1] TF1 *f= new TF1(“f”,“ROOT::Math::conf_hyperg(1,1,x)”,0,10)

this is what i get

Error in TFormula::Compile: Bad numerical expression : "ROOT::Math::conf_hyperg(1,1,x)"
Error in TF1::TF1: function: f/ROOT::Math::conf_hyperg(1,1,x) has 0 parameters instead of 1

I thought the problem was that i had to load the MathMore library, but running the command

root[2] gSystem->Load(“libMathMore”)

i get

Error in TUnixSystem::DynamicPathName: libMathMore[.so | .dll | .dylib | .sl | .dl | .a] does not exist in .::/usr/lib/x86_64-linux-gnu/root5.34:/usr/lib/x86_64-linux-gnu/root5.34/cint/stl
(int)(-1)

I tried again after having installed in my pc the gsl-2.1 library, getting the same results.
What am i doing wrong? How can i fix it?

You seem to be missing the “libroot-math-mathmore5.34” package.

i installed the package, but trying to load MathMore now i get

Error in TUnixSystem::Load: version mismatch, /usr/lib/i386-linux-gnu/root5.34/libMathMore.so = 53414, ROOT = 53430
(int)(-2)

what’s wrong now?

rebooting everithing solved the problem :smiley: :smiley: :smiley:
Thanks :smiley: