Cannot compile ROOT on new ubuntu machine

Hello All,

On a brand new install of Ubuntu 14.04 I cannot install root. Any ideas on how I fix this? Thanks in advance

VM

[code]$ svn co http://root.cern.ch/svn/root/trunk root

$ cd root

root$ gcc --version
gcc (Ubuntu 4.8.2-19ubuntu1) 4.8.2

root$ make -v
GNU Make 3.81

root$ uname -a
…3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

root$ ./configure linuxx8664gcc


Enabled support for asimage, astiff, builtin_afterimage, builtin_llvm, explicitlink, fftw3, fitsio, gviz, genvector, krb5, ldap, mathmore, memstat, mysql, opengl, python, shadowpw, shared, ssl, tmva, x11, xft, xml.

To build ROOT type:

make

root$ make
/home/vm/root/interpreter/llvm/Module.mk:82: *** target pattern contains no `%’. Stop[/code]

Just a guess: have you tried to do “./configure” without parameter to let it decide what is the best system to use ?

Hi,

I know it’s not the answer you asked for, but I recently had some troubles compiling (and then running) ROOT on Ubuntu 14.04 and I solved deleting all /usr/share/root/* files and installing the packages from Ubuntu Software Center.
Please note that TSpectrum, Graphical Fit Panel and other components are provided via separate packages, often with the “plugin” keyword in the name.

If you don’t need to compile with some special configuration (–enable-something) this is probably the fastest solution…

PS: for the records, Ubuntu Desktop 14.04 is not (yet) the LTS version; that is scheduled to come out in June. When I move to that, I’ll report ROOT installation problems :wink:

Yes, I did try ./configure without parameters as well. Same story.

Also I tried both the 5.34 and 5.32 versions.

All in all, I tried four configurations:

5.34: using cmake and "./configure;make"
5.32: using cmake and “./configure;make”

In both cases, cmake proceeds further before crashing.

When using cmake, the error is:

I need to correct this as false: while my 14.04 upgrade was not recognized as “LTS”, when I was asked for more sources about this new “June release” I could find no one, even the one I remember to have read; instead, on official repositories there is only one 14.04 version marked as LTS. I apologize with all forumers.