Building root from source on MacOS 13.3

Dear experts,
I am trying to build root from source as there seems to be no precompiled version for MacOS 13.4. However I keep running into some error while building. The first error is the following:

While building module 'Core':
While building module 'std' imported from input_line_1:1:
While building module 'Darwin' imported from /Applications/
In file included from <module-includes>:1421:
In file included from /Applications/
/opt/local/include/unctrl.h:61:38: error: cannot initialize a variable of type 'char *' with an lvalue of type 'char *(chtype)' (aka 'char *(unsigned int)')
                                     ^               ~~~~~~
/opt/local/include/unctrl.h:61:61: error: expected ';' after top level declarator

As I have only build root from source once and did not have any problems, I do not know how to proceed. Can anyone help?
ROOT Version: 6.28.04
Platform: MacOS 13.4
Compiler: clang

I case somebody else has this problem:
From an old topic Build Error I found out that using make build with -Druntime_cxxmodules=OFF will “solve” the problem. However, I would still like to know what the problem is and how I can solve it.

Maybe @couet can tell when the 13.4 binaries will be available?

I just build master with:

cmake ../root -Dall=ON
make -j8

And it is fine for me on OSX 13.4

Thanks @couet!
That sounds good. Sadly I am not an expert on computers and therefor many things seem confusion to me. So I just followed the guide for “Installing root from source”. At which points do I need to apply these commands and is the file structure the same?

Let me show you the command I did:

git clone root
mkdir rootbin
cd rootbin
cmake ../root -Dall=ON
make -j8
source bin/

Also, note I am on 13.4 … not 13.3 (as the title of your post tells)

Sorry, I seem to have made a typo in the title.
As to your commands, I get an error during the cmake command:

CMake Error at cmake/modules/SearchInstalledSoftware.cmake:615 (message):
  Please enable builtin Glew due bug in latest CMake (use cmake option
Call Stack (most recent call first):
  CMakeLists.txt:327 (include)

If I turn that on, the same error appears.

Clean the rootbin folder and do:

cmake ../root -Dall=ON -Dbuiltin_glew=ON

It should be ok. I did that yesterday on a 13.4 machine.

Sadly that did not work for me. But also the installation of root v6.24 crashes, so probably it is some error with my computer. So I guess, I will just have to wait until a precompiled version is out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.