3D Plotting with TMultiGraph

Hi All,

I have freshly installed root last week (5.32/01) and I am trying to produce a plot similar to the first graphical example on the TMultiGraph doco page:


It came out blank, so I tried to copy the source code of that graph and try to produce the exact sample graph on my laptop, however only a 2D plot with the same green background appeared, with some black shadows in the shape of the different graph overlayed on each other.

Does anyone have a clue what extra packages I need to install to get that going? I am running ubuntu 11.10, and have installed all of the packages listed under ubuntu on ROOT’s Build Prerequisites page, as well as all of the common optional packages.


I copy-pasted all the macros on that page into files on my Imac. They all are working fine.
I will now try on Ubuntu

By the way … why do you name your post "3D plotting… " the 1st example on this page is not 3D…

These macros are fine for me on Ubuntu also.

May I ask what version of root and ubuntu you have tried it on?

I have tried it on two different computers (both 5.32/01), a virtual machine prepared for a root workshop (5.32/02) and lxplus (5.28/00) and none of them worked for the first script…

Sorry I did not think too much when writing the title of the post…


Adding to that, it seems the problem is only with TMultigraph, as I have no problem with the sample source codes on this page



I also get just “black shadows” on an Ubuntu 10.04.4 LTS i686 (tried with ROOT v5-28, v5-30, v5-32/01 and v5-32/02).
I think the problem is that the “3D” option is available in the current ROOT “trunk” only (as of today) and it’s not present in any ROOT “release” (as of today) -> compare: http://root.cern.ch/root/html/TMultiGraph.html with http://root.cern.ch/root/html532/TMultiGraph.html and http://root.cern.ch/root/html530/TMultiGraph.html and http://root.cern.ch/root/html528/TMultiGraph.html
It would be nice if such informations were available in the documentation itself (i.e. where the “3D” option is presented, a note should say that it’s available from ROOT v5-34 onwards).

Exact …