Xrdcp doesn't work after changing ROOT to v6.06.08


When I set variables for self-compiled ROOT v6.06.08 in lxplus, xrdcp gave :

I don’t know what does it mean…

With any pre-compiled ROOT in /afs/cern.ch/sw/lcg/app/releases/ROOT, xrdcp works without any problem.
With self-compiled ROOT v6.00.02 which I want to change from, xrdcp workds without any problem.
With any ROOT, xrdcp in /afs/cern.ch/sw/lcg/external/xrootd/3.2.7 works without any problem.

Compiling option for ROOT seems not to matter.

I need self-compiled ROOT to have more package supports.
I have no idea to solve this problem…

Thanks in advance,

How did you build ROOT? What options did you use?

Hi mato,

I did :

cmake -DCMAKE_INSTALL_PREFIX=../x86_64-slc6-gcc49 -Dbuiltin_xrootd:BOOL=ON -Dpythia6:BOOL=ON -DPYTHIA6_LIBRARY:FILEPATH=/afs/cern.ch/compass/tgeant/TGEANT_REFERENCE/deps/pythia6/v6_428/lib/libPythia6.so ../root-6.06.08/
make -j6
make install

I tired -Dbuiltin_xrootd:BOOL=OFF and I got same error…

Did you try -Dbuiltin_xrootd:BOOL=OFF on a clean build area?
I see what the problem could be. We use a more recent version when to use the builtin one and probably we do not install the command line tools such as ‘xrdcp’, the old command uses the new libraries creating a conflict. Please disable builtin_xrootd.

Hi mato,

As your advice, I tried in new build directory with builtin_xrootd:BOOL=OFF :

cmake -DCMAKE_INSTALL_PREFIX=../x86_64-slc6-gcc49 -Dbuiltin_xrootd:BOOL=OFF -Dpythia6:BOOL=ON -DPYTHIA6_LIBRARY:FILEPATH=/afs/cern.ch/compass/tgeant/TGEANT_REFERENCE/deps/pythia6/v6_428/lib/libPythia6.so ../root-6.06.08/
make install

xrdcp works!
Thank you for your help!