Windows GUI for version 4.02/00

I’m new to root, and installed version 4.02/00 on my Windows 2000 machine, with the binary WIN32GDK version. When I right click on a function or histogram, and choose “drawpanel” I get a TFrame panel instead.

So, I tried 4.00/08 instead. It works normally, so I’m OK with that for now. Any suggestions to get the latest version working?

To get the Drawpanel working, activate the graphics editor from the canvas “View” menu,
then click on the histogram you want to edit.
In the CVS version, selecting Drawpanel from the context menu activates automatically
the editor.


That gets me closer, but I still get only the TF1 style panel popping up when I choose drawpanel, and not the full-featured drawpanel.

Very likely you click on the TF1 (result of a TH1::Fit) and not on the histogram itself.


In the 4.00/08 version, you can get a drawpanel for a hist or a function. In 4.02, I can get a good fitpanel for a hist, but not a drawpanel. (nor for a function). I’ve been using this example to generate a test histogram.

TH1F h1(“h1”,“histo from a gaussian”,100,-3,3);


If you set TUtilPad::SetPanelVersion(1) you will have the old DrawPanel back.

Cheers, Ilka

OK, I get it, there’s a new more elegant drawpanel for histograms (and you have to left-click on the hist first to get it).

It doesn’t work for functions though and I would point out your “getting started” chapter has you trying the GUI and trying histogram options starting from a function object, so new users will be led astray.

But it’s working fine for me now, so thanks for your help!


The chapters “Getting started” and “Graphics nad the Graphical User Interface” will be updated soon according to the recent code changes. If you find that something does not work as it should with both interfaces, please provide a concrete example that shows the problem.

Thank you, Ilka