Why are all my colors (including tool windows) transparent?


I’m having an issue with my root build where all colors in plots and windows are transparent. That’s colors inside things like the color picker too, not just colors on plots. I’ve included an image to show what is going on.

Black and white seem to be opaque, but any other color is transparent.

I’ve tried two different build of root and the same thing happens. One from the centos repository (6-28-04) and one from the pre-compiled binary repo (6-26-10).

The script I used to make the plot in the image was used on another centos 8 machine and the colors were fine. It’s just this particular machine.

This is possibly an issue with my machine rather than root itself considering I haven’t seen anyone else with this problem, but I thought I would post here in case.

Any advice?

_ROOT Version: 6-28-04 and 6-26-10
Platform: CentOS 8
Compiler: GCC 8.5.0

May have solved this myself, or at least I know the cause now. This only seems to occur over remote monitoring. The colors look find when you view on the local monitor and not over a remote connection. Not sure if there is a fix for this within ROOT or if the remote connection details need tweaking. Either way, it’s something I can work with

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.