Where do TGraph's go?

I’m using root 4.02.00 on Linux. When I create histogram objects I can see them in a TBrowser in /root/ROOT Memory/ however when I creat TGraph objects they do not appear there. Am I looking in the wrong place ? Where can I find them ?


By default only TH1, TF1 and TTree are added to the ROOT folders.
If you want to add another object, eg TGraph* gr, do:


Hi Rene - thanks for the reply. I’ve tried this but I get a seg viol when I try to look at the ROOT Memory directory with the TBrowser. All the icons in the directory stack on each other. If I click one of the icons to change the view of the directory then the icons re-appear but the TGraph (actually TGraphErrors) is still not there. I even tried casting it to a TObject before making the ->Append call.

Have you seen this before ?

Could you send the few lines of code where you append your TGraphs to the “ROOT Memory” folder?


Hi Rene,
I knocked up an example, from graph.C and hsimple.C. If you run the script you will see that a graph object appears in the Root Memory folder but if you try to view it after viewing a histogram it seems to not draw any axes, but use the axes of the previous histogram, even if you clear the pad or canvas before drawing.
TGraphTest.C (1.52 KB)