Weird user interface of canvas

Dear Rooters,

I’ve been encountering this problem for a while now and I don’t recall when it started(but definitely after I had installed root on my desktop and used it without any problems for almost a year). The attached screenshot shows a window that pops out when I tried to save the histogram I drew from a root tree. I noticed that I could not tell what the folders are because the letters are so blurred! I built root 6.14 on my desktop running Ubuntu 16.04 following the instructions at I did not specify any build options though.

I did some search on google and did not find any topics related. I don’t even know if this is more of a ubuntu problem or of a root problem. I hope my descriptions are clear enough. Thanks a lot!


ROOT Version: 6.14
Platform: Ubuntu16.04
Compiler: g++ 4:5.3.1-1ubuntu1
g+±5 5.4.0-6ubuntu1~16.04.11


In your “${ROOTSYS}/etc/system.rootrc” file, try to set “X11.UseXft: yes” .

It worked!! Thank you so much!! I didn’t expect it could be this simple.
Do you mind explaining a little why this happens? I’m curious to know.

We have now (in the master) turned Xft on by default.

We have a mechanism that detects whether Xft is available on a machine, and it so uses its fonts. That failed for you, for some unknown reason. But as I said, future ROOT versions will not have that problem anymore.

I see. So it’s about failure to turn on the Ubuntu font package. Thanks for your explanation!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.