Version 5.34.34 build error with MacOSX 10.12 Sierra

Hi I saw some previous similar posts on the same problem but I’still not sure what to do, I don’t think I found the patch release in the website mentioned in the previous post?

After setting the environment variable, I did
./configure macosx64 —with-python-incdir=/Library/Frameworks/Python.framework/Versions/3.5/Headers —with-python-libdir=/Library/Frameworks/Python.framework/Versions/3.5/lib

and it crashed at the make stage, (I should use cmake? but I don’t seem to have this command)
Here is the error:

ex/src/Pointer.o cint/reflex/src/PointerToMember.o cint/reflex/src/PropertyList.o cint/reflex/src/PropertyListImpl.o cint/reflex/src/Scope.o cint/reflex/src/ScopeBase.o cint/reflex/src/ScopeName.o cint/reflex/src/ScopedType.o cint/reflex/src/TemplateInstance.o cint/reflex/src/Tools.o cint/reflex/src/Type.o cint/reflex/src/TypeBase.o cint/reflex/src/TypeBuilder.o cint/reflex/src/TypeName.o cint/reflex/src/TypeTemplate.o cint/reflex/src/TypeTemplateImpl.o cint/reflex/src/TypeTemplateName.o cint/reflex/src/Typedef.o cint/reflex/src/TypedefBuilder.o cint/reflex/src/Union.o cint/reflex/src/UnionBuilder.o cint/reflex/src/VariableBuilder.o -ldl -Llib -lCore -lCint
ld: library not found for -lCore
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [lib/libReflex.dylib] Error 1
make: *** Waiting for unfinished jobs…

The version of my Xcode is 8.2.1 and CLT version: 8.2.0.0.1.1480973914
gcc is ,I think 4.2.1
Any helps are appreciated :slight_smile:

Hi Annie,

v5.34 is frozen per se and is unlikely to work properly on newer XCode/MacOS version (which have a tendency to introduce subtle backward incompatibility at each release).

I strongly recommend that you use ROOT v6.08 instead.

Chees,
Philippe.

Thank you but two extra questions:
Are you saying in general or on behalf of this specific error ?
Do I have to use cmake ?

Hi Annie,

See


how I have compiled root on Sierra using cmake.

Regards,
Christian

1 Like

Yeah, but I don’t think I can use exactly what you used since I need to set up pyroot
so I have downloaded cmake but when I typed
cmake --help
in my terminal, I got “command not found”, are there any extra things I need to do in order to use cmake? Do I need to set up some sort of environment variables in my bash_profile? I don’t know where the path should point to?

Thanks

You need to download and install cmake:
https://cmake.org/files/v3.8/cmake-3.8.0-rc3-Darwin-x86_64.dmg

But that is exactly what I did before, I downloaded one more time and I tried cmake --help, I still get “command not found”…

Never mind, I didn’t install it properly before

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.