V5.34.34 make error in Ubuntu 18.04.2


I am running Ubuntu 18.04.2 and trying to build ROOT v5.34.34 (environment driven build) but I am getting a error during make which I don’t recognize. All of the prerequisite packages have been installed. The error message shows:

ar: u' modifier ignored sinceD’ is the default (see `U’)
libtool: link: ranlib .libs/liblzma.a
libtool: link: ( cd “.libs” && rm -f “liblzma.la” && ln -s “…/liblzma.la” “liblzma.la” )
make[2]: Leaving directory ‘/home/user/Programs/root/core/lzma/src/xz-5.0.3/src/liblzma’
make[1]: Leaving directory ‘/home/user/Programs/root/core/lzma/src/xz-5.0.3/src/liblzma’

Thanks in advance for the advice!

configure.out.txt (9.2 KB)
make.out.txt (458.5 KB)

Hi there

Thank you for the reply. I followed your advice, followed the link to install v5-34-00 patches with git but encountered the same error as before. The output files from the configure and make is attached. Any ideas how I can fix this so that I can install?

Best regards,
JW Brummer

sudo apt-get install curl

Hi again

That worked well and I was able to make root but the make install command encountered problems with finding libASImage.so as shown below:

wiggert@lenovo-130:~/Programs/v5-34-00-patches$ make install
g++ -shared -Wl,-soname,libASImage.so.5.34 -m64 -O2 -Wl,–no-undefined -Wl,–as-needed -o lib/libASImage.so.5.34 graf2d/asimage/src/TASImage.o graf2d/asimage/src/TASPluginGS.o graf2d/asimage/src/G__ASImage.o -Llib -lCore -lCint -ldl -Llib -lGraf -lMathCore lib/libAfterImage.a -lfreetype -lpng -lz -lz -lXpm -lXext -lX11
lib/libAfterImage.a(export.o): In function ASImage2jpeg': export.c:(.text+0xd5c): undefined reference tojpeg_std_error’
export.c:(.text+0xd76): undefined reference to jpeg_CreateCompress' export.c:(.text+0xd83): undefined reference tojpeg_stdio_dest’
export.c:(.text+0xdbe): undefined reference to jpeg_set_defaults' export.c:(.text+0xde1): undefined reference tojpeg_set_quality’
export.c:(.text+0xdee): undefined reference to jpeg_start_compress' export.c:(.text+0xeac): undefined reference tojpeg_write_scanlines’
export.c:(.text+0xf62): undefined reference to jpeg_set_defaults' export.c:(.text+0xf7a): undefined reference tojpeg_start_compress’
export.c:(.text+0x1037): undefined reference to jpeg_write_scanlines' export.c:(.text+0x1069): undefined reference tojpeg_finish_compress’
export.c:(.text+0x1071): undefined reference to jpeg_destroy_compress' export.c:(.text+0x10c0): undefined reference tojpeg_set_quality’
lib/libAfterImage.a(import.o): In function jpeg2ASImage': import.c:(.text+0x2577): undefined reference tojpeg_std_error’
import.c:(.text+0x25bc): undefined reference to jpeg_CreateDecompress' import.c:(.text+0x25c9): undefined reference tojpeg_stdio_src’
import.c:(.text+0x25d6): undefined reference to jpeg_read_header' import.c:(.text+0x262f): undefined reference tojpeg_start_decompress’
import.c:(.text+0x26cc): undefined reference to jpeg_read_scanlines' import.c:(.text+0x27bf): undefined reference tojpeg_abort_decompress’
import.c:(.text+0x27cc): undefined reference to jpeg_destroy_decompress' import.c:(.text+0x27e9): undefined reference tojpeg_destroy_decompress’
import.c:(.text+0x28d1): undefined reference to `jpeg_finish_decompress’
collect2: error: ld returned 1 exit status
/home/wiggert/Programs/v5-34-00-patches/graf2d/asimage/Module.mk:221: recipe for target ‘lib/libASImage.so’ failed
make: *** [lib/libASImage.so] Error 1

Again, I have installed ROOT many times but not seen this error before and I don’t know why. Do you perhaps have any suggestions?

Thanks in advance

Try to remove everything and start from scratch again (i.e. from downloading the source code).

BTW. If you build ROOT “in-place” then you don’t need to install it.