Using Fastjet with ROOT


I am attempting to use the Fastjet software within a ROOT program. I have tried everything I can think of to properly link the fastjet libraries to my program, but I am still getting error messages such as:

Error: cannot open file "fastjet/ClusterSequence.hh" /cluster/home/j/b/jburzy01/HEP/results/ *** Interpreter error recovered ***


In the above error message, the include path is not the correct path despite me trying both the commands

.include /path/to/fastjet/include


gSystem->AddIncludePath("-I /cluster/home/j/b/jburzy01/HEP/results/fastjet-install/include/");

I have tried using gInterpreter instead of gSystem, I have tried everything with -I and without -I. I am truly at a loss and none of the other posts on this topic have helped. Does anyone have any ideas on how to get fastjet to work?



Well, check that the file “/cluster/home/j/b/jburzy01/HEP/results/fastjet-install/include/fastjet/ClusterSequence.hh” really exists.

In any case, both commands should work fine: gInterpreter->AddIncludePath("/cluster/home/j/b/jburzy01/HEP/results/fastjet-install/include"); gSystem->AddIncludePath("-I/cluster/home/j/b/jburzy01/HEP/results/fastjet-install/include"); Try: std::cout << gInterpreter->GetIncludePath() << std::endl; std::cout << gSystem->GetIncludePath() << std::endl;
BTW. I suspect that your “” does not contain any ROOT dictionary, so you will always need to pre-compile your macros using ACLiC (i.e. “interpreted code” that tries to use “” classes / functions will not work).