Home | News | Documentation | Download

Unix.*.Root.MacroPath issue

Hi all !

I was trying to use ROOT TMVA and it has messed up the macro path followed by ROOT. This path leads to /tmva/test instead of going to my personal directory. Thus, I am unable to load or execute any of my personal macros. I think that this line :

echo “Unix.*.Root.MacroPath: $ROOTSYS/tmva/test” >> .rootrc

has lead to my issue. I tried to use it in order to change the settings in .rootrc (gROOT->GetVersion()) but it hasn’t changed anything. I also tried to use the ROOT tutorial in order to set the environment variables but it also hasn’t worked. Do you know if there’s a way to reset this path to its default configuration or if I can somehow choose the path to be directed to my personal directories?

Thank you for your answers !

ROOT Version: 6.20/06

Hello @MonkeyTommy,

You can edit your .rootrc file and change the value of the Unix.*.Root.MacroPath variable accordingly, e.g. you can include . to search in the current directory. Directories can be separated by the : character.

Alternatively, you can temporarily set the macro search path during a session by

root [0] gROOT->SetMacroPath(".:your_macros/:other/");

I hope this solves your issue.

Cheers,
J.

1 Like

How do you edit the .rootrc file ?

You can edit it with your text editor of preference.

It should be located either in the directory where you are invoking root from, or in your home directory, i.e. ~/.rootrc.

Fixed it, tank you !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.