Ubuntu is broken down after have installed Root

I use Ubuntu 12.04 but it seem gives troubles with root.
Monday I have installed Root on my pc following this step:

sudo apt-get install curl build-essential gfortran subversion cmake \ libmysqlclient-dev xorg-dev libglu1-mesa-dev libfftw3-dev libssl-dev \ libxml2-dev libtool automake

I added at the bottom of /.bashrc this code:

source $HOME/root/bin/thisroot.sh

Then I have dowloaded and extracted Root in my Home and then:

./configure make source $HOME/.bashrc

And it was all ok. It run!!!

But the day after when I started my pc it displayed me that sign on black screen:

could not write bytes: Broken pipes

Then I have tried to go in Recovery mode and delete from ./bashrc the code I wrote but it wasn’t here!!! So I tried to rewrite it here but the problem is not resolved. How can I do?


this really looks like a misconfiguration of your system rather than an issue of ROOT.


Indeed this problem has nothing to do with ROOT - ask on Ubuntu’s forums or somewhere else what/where/how/at what time you can execute (scripts etc.) I once made the same thing as you and got another problem - I was not able to login anymore. This was Ubuntu 13.10 working as a VirtualBox machine. At the end I’ve just deleted thisroot.sh from .bashrc and it helped.