Ubuntu Install library error

Hello Root People,

I’ve been trying unsuccessfully for a while to install root on my ubuntu laptop. I’ve been following this series of steps but when I get to the part where I have to install the various libraries with “cmake …/root-6.10.04/ -Dall=ON” I get an error message

CMake Error at cmake/modules/SearchInstalledSoftware.cmake:825 (message):
The Alien plugin requires option ‘xrootd’ to be enabled. Re-run the
configuration with ‘xrootd=ON’

I’m very new to ROOT so I have no Idea what this means or how to fix it. Any help would be much appreciated.

Thanks guys

1 Like

The ROOT team provides ready-to-use binary distributions for some systems, including various Ubuntu versions, which you just need to download and unpack.

Hi, I downloaded the tar.gz file for Ubuntu 18 and extracted it. Where do I go from here to start using ROOT. Is there an Icon I press to load the program? Or is it more complicate than that?

I’m sorry, I’m just not used to this interface. I’m going through the README and at the stage when I input the build command cmake–build I get this

You are supposed to read the “README/README” file which is provided inside of the binary distribution.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.