Ubuntu: Error in cling cannot extract standard library include paths

This question has been posted before, but none of the proposed fixes worked for me. I’m working off a fresh installation of root, and when start root from command line or try to run a macro, I get the following error:

ERROR in cling::CIFactory::createCI(): cannot extract standard library include paths!
LC_ALL=C x86_64-linux-gnu-g+±7 -O3 -DNDEBUG -xc++ -E -v /dev/null 2>&1 >/dev/null | awk ‘/^#include </,/^End of search/{if (!/^#include </ && !/^End of search/){ print }}’ | GREP_OPTIONS= grep -E “(c|g)++”
Results was:
With exit code 256

I then see the ROOT prompt, and can open and view files in a TBrowser, but when I run some macros, I see the following:

pres.cpp:81:10: error: qualified member access refers to a member in namespace ‘std’
std::cout << center << std::endl;

Any help is appreciated.

ROOT Version: 6.16/00
Platform: Ubuntu 21.04
Compiler:Ubuntu 10.3.0

You seem to be using ROOT binaries which were compiled by “x86_64-linux-gnu-g++-7” which are not compatible with your operating system (and your compiler).

Thanks for identifying the issue - how can I fix it?

You need to build ROOT from source.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.