Typing the error: Assertion failed. "Isn't a single decl"

Please read tips for efficient and successful posting and posting code

ROOT Version: v6.28.00
Platform: Not Provided
Compiler: Not Providedw___
hi everyone.I am facing the following problem: Here is my C code:
When i run it,it show the next error:
Assertion failed: isSingleDecl() && “Isn’t a single decl”, file C:\build\ws\BUILDTYPE\Release\LABEL\windows64\V\6-28\root\interpreter\llvm\src\tools\clang\include\clang/AST/DeclGroup.h, line 84

How can i treat this?

TGraph *g = new TGraph();

1 Like

Can you give more details? Which exact version of ROOT did you install (64 bit or 32 bit)? Which exact version of Visual Studio do you have on your computer? Where do you start ROOT from? How do you run your code?

i did it with no result

I have the 6.28.00 (64 bit). I use the Microsoft visual studio code 2022. I run my code from root terminal.I saved it with .c.

you forgot the declaration of i: for (i = 0;i<10; i++)for (int i = 0;i<10; i++)

1 Like

You are right.Thank you.I used to run python code,so i need some time in order to get used the c code again.Thanks for your help!

1 Like

You’re very welcome!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.