TTreeIndex write crash

Dear rooters,

I tried to use an user defined TTree indexation in order to merge two TTrre with timestamped data.
One of the two TTree is in fact a TChain with about 500 files and I faced the ordering issue which is
explained in several posts.
I then directly created a TTreeIndex, no complain from ROOT. But when I try to write it into a file, it exits without any error message and the resulting TFile is of course corrupted.
I tried with less files in my TChain : it works.
I assume that the problem is the size of the generated TTreeIndex/TFile but I estimated it to be lower than 1 Go
Any help appreciated.

_ROOT Version: v5-34-36
_Platform: Scientific Linux 6
Compiler: gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-18)

Hi Julien,

do you see the same crash with a recent ROOT version, e.g. v6-14-00? That ROOT version is old and development of the ROOT5 series stopped years ago.


Thank you for your answer.
I tried w/ ROOT 6 it seems to work but it is unstable.
Now I have an error message

#0 0x00007fb2b5a3a07a in __GI___waitpid (pid=27515, stat_loc=stat_loc
entry=0x7fff5d44ea40, options=options
entry=0) at …/sysdeps/unix/sysv/linux/waitpid.c:29
#1 0x00007fb2b59b2fbb in do_system (line=) at …/sysdeps/posix/system.c:148
#2 0x00007fb2b6615322 in TUnixSystem::Exec (shellcmd=, this=0x1473570) at /opt/cern/root/root-6.14.00/core/unix/src/TUnixSystem.cxx:2119
#3 TUnixSystem::StackTrace (this=0x1473570) at /opt/cern/root/root-6.14.00/core/unix/src/TUnixSystem.cxx:2413
#4 0x00007fb2b6617bf3 in TUnixSystem::DispatchSignals (this=0x1473570, sig=kSigSegmentationViolation) at /opt/cern/root/root-6.14.00/core/unix/src/TUnixSystem.cxx:3644
#6 0x00007fb2b42a14ee in tobuf (x=0, buf=
0x347b828: 0x388dfff “”) at /opt/cern/root/root_v6.14.00/include/Bytes.h:202
#7 tobuf (x=0, buf=
0x347b828: 0x388dfff “”) at /opt/cern/root/root_v6.14.00/include/Bytes.h:440
#8 TBufferFile::WriteFastArray (this=0x347b800, ll=0x7fb065e0e010, n=) at /opt/cern/root/root-6.14.00/io/io/src/TBufferFile.cxx:2080
#9 0x00007fb2a8cfe80a in TTreeIndex::Streamer (this=0x237ca40/build/gdb-9un5Xp/gdb-7.11.1/gdb/stack.c:625: internal-error: print_frame_args: Assertion `nsym != NULL’ failed.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

You should create an index for each TTree within the chain (i.e. individually).