TSQLServer::HasTable: is it expected to work with oracle DB?


I have been using root to access an oracle db at CERN for more than a year without any problem. Now I am trying to use something more than TSQLServer::Query : I’d like to use TSQLServer::HasTable but when I try with a table name I am sure it exists I receive a null pointer.
Similar behaviour when I try GetTableList: a null pointer to a TList is returned

Is there known issue with these methods?




I have just checked that with a mysql db HasTable seems to work fine.


Hi, Andrea

Can you try following code:

  TSQLServer* sql = TSQLServer::Connect(...);

  TList* lst = sql->GetTablesList();

  if (lst!=0) {
     delete lst;

  delete sql; 

Do you see your table in printout? It also can be problem with upper or lower case.

Regards, Sergey

Thanks Sergey,

you were right, in the Oracle db the table names are with CAPITAL letters. I thought I had tried to get the list of tables but I had the impression I got an null pointer. But this morning it worked so, likely, it was me who did something wrong.