hi all,

I am struggling with troubleshooting a TSQLServer connection issue due to a lack of error messages. On one of my machines I can connect without problem to an example host using the mysql command line tool:

mysql -h host.edu -u readonly
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1792011

However, when I try to connect using TSQLServer it doesn’t create an object and no error message is given:

root [0] TSQLServer *f_db = TSQLServer::Connect(“mysql://host.edu/test”,“readonly”,"");
root [1] if (! f_db) cout<<“error”<<endl;

Is there a way to find out why f_db was not created?

best regards,


do you have the MySQL plugin for ROOT compiled? You should have $ROOTSYS/lib/libRMySQL.so

Cheers, Fons.

I’m trying to get root to recognize mysql on windows 7 64-bit. I have the community version of mysql 5.6 installed. I’ve tried the MSI installer and CMake. The MSI installer doesn’t recognize the existence of mysql and doesn’t build librmysql.so. CMake also doesn’t recognize the existence of mysql. I’ve tried installing root using cygwin, but ran into further problems. Any ideas?


do you have the MySQL plugin for ROOT compiled? You should have $ROOTSYS/lib/libRMySQL.so

Cheers, Fons.[/quote]

Where can we find instructions for including this plugin in ROOT’s build?

Make sure the dev libraries for the myself client lib are installed on your machine and run ./configure;make.
See also:

root.cern.ch/drupal/content/inst … oot-source

Cheers, Fons.