Trouble with libaries after installation


I am trying to get ROOT v5.24.00 installed and working correctly on Ubuntu 9.04 (Jaunty Jackalope). I just recently installed Ubuntu so that I can dual-boot between it and Windows Vista. As such, I am still in the process of learning how to fully use linux. (Basically, assume that I probably don’t know what I’m doing if something requires going beyond the basics of linux)

I am following the instructions on for building from source with a fixed directory installation.
When I type the command “root”, the splash screen shows up, but I get this error in the terminal:
tyler@Tyler-Laptop:~$ root
/usr/local/bin/root.exe: error while loading shared libraries: cannot open shared object file: No such file or directory

I have found that if I go into /usr/local/bin and do: “.” it will work. Do I have to do that every time, or is there something else I should do? If I am to do that every time, is there a way to make the terminal automatically do that? (from what I understand about that terminal, I could put it in a script somehow, I just don’t know how to do it)

Once it is running, I am having issues with getting the GDML libraries to work correctly. When looking at the README, I found that I have to include “–enable-gdml” in the ./configure command, which I did. But, once I have ROOT running, when I try to import it with: “TGeoManager::Import(“test.gdml”);” I get this error:
root [1] TGeoManager::Import(“test.gdml”);
Info in TGeoManager::Import: Reading geometry from file: test.gdml
Error in TXMLEngine::ParseFile: Unexpected end of xml file
Error in TGeoManager::Import: Cannot open file

Any idea what is going wrong here/why it won’t import it? I have ROOT running on the Vista partition of my laptop and the file will correctly import on that, so it can’t be the file. I noticed that that is the same error I got when I tried importing a GDML file onto an old version of ROOT (prior to ROOT have support for GDML). The old version was on a desktop at work.


Concerning the install, add the /usr/local/lib/root (or where ever the ROOT libs are) to /etc/

Cheers, Fons.

Could you attach the gdml file ?