Trouble running tutorial

I’m starting all the way from the bottom. PROOF looks nice and I want to learn to use it. I started with the example at $ROOTSYS/tutorials/proof/runProof.C.
I tried to run a simple example with the instructions provided, and this is what I get:

root [0] .L proof/runProof.C+ root [1] runProof("h1") getProof: tutorial dir: /tmp/simon/.proof-tutorial SysError in <TUnixSystem::UnixTcpConnect>: connect (localhost:11093) (Connection refused) getProof: xrootd config file at /tmp/simon/.proof-tutorial/ getProof: xrootd log file at /tmp/simon/.proof-tutorial/xpd-tutorial/xpd.log (NB: any error line from XrdClientSock::RecvRaw and XrdClientMessage::ReadRaw should be ignored) getProof: waiting for xrootd to start ... getProof: xrootd pid: 2009 getProof: start / attach the PROOF session ... 100304 13:53:51 001 Proofx-E: Conn::Connect: failed to connect to proof://simon@localhost:11093// 100304 13:53:51 001 Proofx-E: XrdProofConn: XrdProofConn: severe error occurred while opening a connection to server [localhost:11093] getProof: starting local session failed runProof: could not start/attach a PROOF session root [2]
I’ve tried disabling the firewall, that didn’t help. Btw, I’m on Mac, it shoud still work though, right?

Also I found only very limited documentation on PROOF. If anyone has a nice tutorial, please give me a link. Even better would be a working, compiling example of looping over an Ntuple while producing a histogram. Any help will be appreciated.

Ok, I found out by myself that it’s a setup issue. One needs to follow the steps in $ROOTSYS/README/README.PROOF and that should take care of everything.

My problem now is entirely different: The readme specifies setup instructions for inetd and xinetd, but I found out that these services have been replaced by launchd on Mac. So my problem is now how do I set up launchd correctly. Does anyone have experience with this?

Dear Simon,

Well, that’s for the discontinued daemon proofd.

The documentation we have is at

This said, ‘runProof’ should take care of doing all what you need by itself, so your problem is not normal. However, we saw problems on Mac with Unix sockets, so it maybe that you are facing something like that. Please post /tmp/simon/.proof-tutorial/xpd-tutorial/xpd.log and all the other .log files that you should find under /tmp/simon/.proof-tutorial/proof/simon/… .

G. Ganis

Ok, so I checked the logfile at /tmp/simon/.proof-tutorial/xpd-tutorial/xpd.log It’s not long, so here it is

Copr. 2007 Stanford University, xrd version 20091202-0509 ++++++ xrootd initialization started. Config using configuration file /tmp/simon/.proof-tutorial/ =====> xrd.adminpath /tmp/simon/.proof-tutorial/admin =====> xrd.port 11094 =====> xrd.protocol xproofd Config maximum number of connections restricted to 10240 100305 09:33:31 001 XrdgetPlugin: Unable to open dlopen(, 2): image not found 100305 09:33:31 001 XrdgetPlugin: Unable to open dlopen(, 2): image not found 100305 09:33:31 001 XrdProtocol: Protocol xproofd could not be loaded ------ xrootd initialization failed.
It seems that can’t be found which looks like an installation issue. I installed from source 3 months ago and haven’t encountered any other issues so far, so I find that strange, maybe the reason is something else.

The folder /tmp/simon/.proof-tutorial/proof does not exist, so there are no logfiles there.

I guess ROOTSYS is defined in your setup and $ROOTSYS/lib is in the path of the dynamic loader (i.e. you did execute 'source $ROOTSYS/bin/ ’ or similar environment setting script).

Can you find under $ROOTSYS/lib ?

G. Ganis

I found out that the reason it didn’t work was that my environment variables were not set up. I thought this was not necessary when installing in a central location. I installed in /usr/local/root. Root runs and I can compile without ROOTSYS being set up (I use the root-config in all my Makefiles), but apparently PROOF needs it. So now I’m using in my .bash_profile to set up ROOTSYS and runProof works out of the box now.

Thanks for your help.