Trouble running Tspectrum example

Hi all,

I’ve got a good amount of experience with Python and Matlab and am interested in the Gold Deconvolution part of the TSpectrum module.

I’ve tried to run Deconvolution_8C as a macro and got a whole bunch of errors relating to the library loading and “maybe you need to load the corresponding shared library”

Where am I going wrong here? Looking through the other forum reports on similar issues, there was a number of points that you can’t just run the macro as is.


ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

This should run without problems:

[...]$ root ${ROOTSYS}/tutorials/spectrum/Deconvolution.C

Thanks for the quick reply, for some reason even though I installed via instructions for Centos on the website, none of the tutorials can be found.

That’s why I copied the code for Deconvolution_8C into a seperate .cc file and tried to run it on its own from the home folder.

I’m on ROOT 6.22/08 on Centos 7 64 bit.


Try a pre-compiled binary distribution.

All working now, thanks for the help