Trouble linking against ROOT libraries

Getting unresolved references when building a G4 program against the ROOT libraries. See the error here. I suspect this is more of a C++/Linux/GNU issue than a pure ROOT issue, but after googling around a bit without much success I figure this community might have some insight.

Building ROOT 6.24.04 from source. The ROOT build succeeds. The linking of the Geant4 program against ROOT succeeds on Fedora 35, CentOS 7, RHEL 7, and RHEL 8. But not on Ubuntu 20.04. I’ve tried adding the line-up of ROOT libraries multiple times in the link command (that line up being -lCore -lImt -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lROOTVecOps -lTree -lTreePlayer -lRint -lPostscript -lMatrix -lPhysics -lMathCore -lThread -lMultiProc -lROOTDataFrame) but I always get the same error.

Any help appreciated. If more info would be useful, let me know. And thanks in advace.

Please read tips for efficient and successful posting and posting code

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

The missing classes are not from ROOT.

OK. Doh. Geant4 classes then. But that really does help, so thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.