Trouble installing ROOT 6 Ubuntu 15.10, GCC cling error

Hi guys,

I’ll preface this by saying I’m totally new to Linux so these might be some very trivial and noob-ish mistakes.

So I’ve been trying to install root via the quick installation, and ran into a few hickups along the way. However now I’m stuck at the cmake --build, when executing:

[ 13%] Building CXX object interpreter/cling/lib/Interpreter/CMakeFiles/clingInterpreter.dir/CIFactory.cpp.o

Throwing me these errors

/home/david/programs/cernroot_2/root/interpreter/cling/lib/Interpreter/CIFactory.cpp:530:4: error: #error "cling does not support the GCC 5 ABI yet."
 #  error "cling does not support the GCC 5 ABI yet."
/home/david/programs/cernroot_2/root/interpreter/cling/lib/Interpreter/CIFactory.cpp:531:4: error: #error "See"
 #  error "See"
interpreter/cling/lib/Interpreter/CMakeFiles/clingInterpreter.dir/build.make:175: recipe for target 'interpreter/cling/lib/Interpreter/CMakeFiles/clingInterpreter.dir/CIFactory.cpp.o' failed
make[2]: *** [interpreter/cling/lib/Interpreter/CMakeFiles/clingInterpreter.dir/CIFactory.cpp.o] Error 1
CMakeFiles/Makefile2:8979: recipe for target 'interpreter/cling/lib/Interpreter/CMakeFiles/clingInterpreter.dir/all' failed
make[1]: *** [interpreter/cling/lib/Interpreter/CMakeFiles/clingInterpreter.dir/all] Error 2
Makefile:136: recipe for target 'all' failed
make: *** [all] Error 2

A quick google search wasn’t too fruitful. My basic English comprehension skills suggest to me that my GCC version that came with Ubuntu 15.10 is incompatible, so my thought is either find a way to rollback to an older GCC version, or reinstall Ubuntu to a LTS distribution. I don’t have much on my Linux hard drive so this isn’t too daunting for me. Any other suggestions?

Thanks for the help in advance!


Indeed, those are currently your best options. I expect this to be fixed for the next release, in about four months (and before that, arriving in the master in about six weeks).

Cheers, Axel

Dear Erazoender,

As a workaround, to build ROOT in a minimal configuration, which could be sufficient for you, you can try by configuring cmake with the additional switch



cmake -DCMAKE_CXX_FLAGS=-D_GLIBCXX_USE_CXX11_ABI=0 <other switches> <source dir> 

G Ganis

I have managed to install complete ROOT 6 on Ubuntu 15.10, please follow this:

It is based on configuring an older gcc compiler easily through the package manager

So I went through the reinstalling Linux route, and it successfully built (yay!). However I’m now stuck on the last step of the quick build instructions, where I’m to setup the environment to run:

$ source /path/to/install-or-build/dir/bin/

I was trying to run the following:

david@d-tpy12:~/programs/rootbuild/build$ source /home/david/programs/rootbuild/build/dir/bin/
bash: /home/david/programs/rootbuild/build/dir/bin/ No such file or directory
david@d-tpy12:~/programs/rootbuild/build$ root
The program 'root' is currently not installed. You can install it by typing:
sudo apt-get install root-system-bin

So I’m doing something wrong. My build directory is ~/programs/rootbuild/ .

Any further help would be appreciated! Thanks for the replies so far.

It should read


depending on if you created a subdirectory. Just look for the file with your nautilus.

I’m a moron, found the file! Thank you guys, it’s installed!

You are welcome.

Remember to click on the green arrow of the post (Mark as solved), accepting the answer of the thread that solved the problem.