Trouble finding CMakeLists.txt

ROOT Version: root_v6.20.04
Platform: Linux Mint 19.3 Tricia
Compiler: gcc 7.5.0
CMake version: cmake 3.15.2.

Hi, everybody!

I’m trying to install root_v6.20.04 in my Linux Mint, but I’m having some troubles to find the CMakeLists.txt file.

Linux Mint 19.03 is based on Ubuntu 18.04, so I downloaded the apropriated file from the Download page.

The source files are alocated in my /opt directory:

I created a build directory and from there I tried to run the cmake comand:

coweh@TARDIS:/opt/ParticlePhysics/build$ sudo cmake /opt/ParticlePhysics/root_v6.20.04/

but I received this error message:

CMake Error: The source directory "/opt/ParticlePhysics/root_v6.20.04" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

I find out that there is only a CMakeList.txt file inside the “tutorials” sub directory.

I know this is a dumb question, but I’m a little lost here. I tried the same steps in my Ubuntu machine and everything went smooth.

Thank you all in advance.

From what you write, it seems to me that you took one of the ready-to-use binary distributions which are provided by the ROOT team, which you just need to download and unpack (see “Using binaries” therein).

Wile, you absolutely right!
I downloaded the binaries by accident!

Thank you!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.