TPythia6 woes

Hi fellow Rooters,

I’m using Root 4.04-02 (also tried 4.03, see below) and recently I’ve attempted to run Pythia6 with this version without success – the same script ran wonderfully on previous Root versions (4.02).

Now I get the following error:

  *                                         *
  *        W E L C O M E  to  R O O T       *
  *                                         *
  *   Version   4.03/04     24 April 2005   *
  *                                         *
  *  You are welcome to visit our Web site  *
  *            *
  *                                         *

FreeType Engine v2.1.3 used to render TrueType fonts.
Compiled for linux with thread support.

CINT/ROOT C/C++ Interpreter version 5.15.169, Mar 14 2005
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0] gSystem->Load("")
root [1] gSystem->Load("")
root [2] gSystem->Load("")
root [3] TPythia6 *pythia
root [4] pythia = new TPythia6()
/usr/bin/root.exe: relocation error: /usr/lib/root/ undefined symbol: pythia6_common_address

Looking at, I find a similar symbol, pythia6_common_block_address. Could this be a typo in Root code?

Thanks in advance.


try update your (and after recompile your root lib)
Last version of pythia.tar.gz (on root ftp page) is from 19apr2005.
Pythya6 and root 4.04.02b running without any problem on my system.


Hi muninsky and thanks for your help.

After some struggle I finally got it working. The pythia6 package used for Root suffered some small changes other than the Pythia6 source upgrade, so it wasn’t only a matter of recompiling Root after all…

In summary,

  1. Download and compile the new Pythia6, ROOT-flavoured source code.
  2. Compile with Root 4.04/02b: configure, make, make install.
  3. ldconfig :slight_smile:
  4. Start working.

Anyway, it works now. One more satisfied costumer! :smiley: