TNtuple->Draw using Form


I have this trivial problem that I can’t resolve.

This is the complete macro (called, running on a server with Root Version 3.05/07 25 September 2004 (of course, I can’t change it, but it is not too old) :

int tankid=673;

but I get this error message:
root [7] .x
Limitation: Variable argument is not supported for this platform LINE:3
*** Interpreter error recovered ***

of course, there is no problem when running with the commented line, and commenting the one with Form.

Then, I tried running the same code on my laptop with Root Version 4.04/02 8 June 2005, and “Voila!!!” it worked perfectly. (both ways of course).

Could someone please tell me if it is a problem of the root version, or I’m doing something wrong…

ROOT 3.05/07 is from July 2003 (not September 2004).
This version did not accept Form in a script.
This should be OK with versions 4 or newer.


well, you are right, the interpreter version is 2003. But installing a new version is not an option for me. So, what else can I use instead of Form? is there another way to use a variable inside a Draw function?

Ok, I already figured it out. This is the code that runs on the old version:

int tankid=673;
char tankidchar[20];