TMVA with NeuroBayes issues

Hi All,

As the title suggest I am trying to enable the NeuroBayes method from within TMVA.

I am trying to do this on the lxplus servers, since this is where the NeuroBayes license resides. I have attempted this two ways, using the guide here for…well, guidance:

The first method is use their plugin, in which case I have to download a new version of TMVA from their website and compile it with the NeuroBayes (NB) plugin. So if I do these steps:

Setup root (originally used 5.30.00, also tried 5.28.00)
Compile TMVA with NB plugin
Compile NB plugin itself, set up library path, edit .rootrc file

I get this error:

dlopen error: /afs/ undefined symbol: ZN4TMVA10MethodBase24OptimizeTuningParametersE7TStringS1
Load Error: Failed to load Dynamic link library /afs/[/quote]

It seems like something is going awry when making the .so file when compiling the plugin, but I have tried it several times, and I always get the exact same message.

The next method was to try using root version 5.22.00 since they say you don’t need the plugin for this, but when I simply set up root 5.22.00 and try to run, I get this message:

[quote]Error in TUnixSystem::DynamicPathName: TMVANeuroBayes[.so | .sl | .dl | .a | .dll] does not exist in /afs/…/lib:/afs/
— Factory : Couldn’t load any plugin for NeuroBayes.[/quote]

Now, this may be due to the fact that there is a different syntax that I have to place in the .rootrc file to enable the plugin…does anyone know the old syntax, or have any other ideas?

Any help greatly appreciated!