TGuiBuilder not writing .C output in ROOT v6.26/00?

I’m observing that in ROOT v6.26/00, TGuiBuilder is no longer writing its output in a .C macro,
generating the following one-liner

// Mainframe macro generated from application:

instead. I do not see the same problem when running TGuiBuilder v6.18/04.on the same platform.

Unfortunately, as the TGuiBuilder has a GUI interface, I cant provide a macro to illustrate the problem.

Is that a know issue ?

– regards, Pavel Murat

_ROOT Version:6.26/00, Fermilab build
_Compiler:g++ (GCC) 9.3.0

I cannot reproduce the problem, at least with ROOT master (6.27/01) on Windows. I’ll check on Linux. Note that TGuiBuilder is not developed anymore.

EDIT: I just tried on Ubuntu 20.04.4 LTS and it works as well

Hi Bertrand, thanks for looking into it!

It is possible that the problem is specific for a given version - I’ll try to contact local ROOT support at Fermilab then.

The ROOT GUI builder is as good as pretty much any other GUI builder (say,PyQT*…),
so it should be enough just to keep it running.

– regards, Pavel Murat

It might be, but I doubt, since I don’t see what could cause this weird behavior…

Hi Bertrand, adding to my confusion:

  • when I tried to demonstrate the problem to someone else here at Fermilab,
    I wasn’t able to do that - I placed a few buttons on a frame and successfully saved the result into a ROOT macro…

Not sure what resolved the issue - apparently there was something of an operational nature I didn’t control. An anomalously huge NFS delay could give an example of an explanation - I was writing
to an NFS-mounted disk .

This topic can be closed. Thanks again for spending time on what happened to be a red herring.

– regards, Pasha

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.