TGTextView and TGTextEdit not displaying text

ROOT Version: 6.16/00
Platform: MacOS 10.14.2
Compiler: Apple LLVM version 10.0.0 (clang-1000.11.45.5)

Hi guys! I’ve noticed the TGTextEdit is not displaying the text on macOS. Using xQuartz 2.7.11. Attached please find a screenshot of the /tutorials/gui/guitest.c

I’ve tried TGTextView and it seems to have the same issue. Screenshot is attached below:


I think this is similar of the issue you have:

Hi I’ve tried running the /tutorials/gui/guitest.c in interpreted mode as well as I did compile an executable. It does not seem to make any difference. Widgets do not display any text. We do take advantage of this widget in the software. Any workarounds?

Well, I don’t have any Mac to try it out, and I’m away until next week, so I’m afraid I can’t really help for the time being…

Should I go report the issue in Jira?

Yes, feel free to open a bug report in Jira

Link to the JIRA bug:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.