TEve Crashing CENTOS7


When trying to load a root eve tutorial (alice_esd_split.C), the display is able to load, however, when I try to interact with the event it segfaults with no backtrace. Previously I was working on a SLC6 machine and there was no issue, but this problem occured when I upgraded to a CentOS7 machine.

The CentOS7 machine I’m using has a AMD Radeon R5 430 graphics card installed and I’m using the radeon driver which ships with CentOS7. I tried this using root v6.16.00 and v6.06.08 and the same error occurred.

This issue seems very similar to that described here: Problem with EVE tutorial triangleset.C

Does the highlighted issue in this thread also affect Radeon graphics card and is a workaround to this known?

Thanks in advance for your help.
Best Wishes


That’s https://sft.its.cern.ch/jira/browse/ROOT-9965 and likely https://sft.its.cern.ch/jira/browse/ROOT-7744 - which is with RedHat. LHCb folks are also after getting this fixed. For now we’re stuck; a workaround will be to use a different GL driver (sw_rast). @matevz - how’s that done again, wasn’t there an env var?



This a link to CMS Event display troubleshooting entry:

I short, set:
export GALLIUM_DRIVER=softpipe
export DRAW_USE_LLVM=0


1 Like

Dear Axel and Matevz,

Thank you very much for your quick responses. Setting those environment variables did resolve the issue. Good luck working on the permanent fix, but for now this is ideal for my use case.

Best Wishes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.